Comment transformer un Raspberry Pi en routeur de voyage sécurisé par VPN

Souhaitez-vous écrire votre mot de passe sur un morceau de papier et le coller sur votre front? Probablement pas. Pourtant, se connecter à un réseau Wi-Fi public est presque aussi stupide.

Cependant, vous n’avez peut-être pas le choix si vous êtes sur la route et que vous souhaitez rester connecté. Un VPN peut vous protéger, mais chaque appareil doit se connecter séparément, sauf si vous utilisez un routeur de voyage comme intermédiaire.

Vous n’en avez pas à portée de main? Ne vous inquiétez pas, vous pouvez en construire un avec un Raspberry Pi. C’est le choix parfait pour un routeur de voyage VPN DIY, alors laissez-nous vous expliquer comment en créer un.

Ce dont vous aurez besoin

Pour commencer à créer un routeur de voyage VPN Raspberry Pi, vous aurez besoin de:

  • Raspberry Pi (Pi 3 ou Raspberry Pi Zero W préféré) avec étui
  • Un seul adaptateur Wi-Fi USB (deux, si vous utilisez un ancien Raspberry Pi)
  • Une carte microSD avec au moins 8 Go de stockage
  • Un lecteur de carte SD
  • Une alimentation de haute qualité
  • PC avec un client SSH installé
  • Un abonnement VPN avec support OpenVPN

Il est possible d’utiliser des modèles Pi sans Wi-Fi intégré, mais vous aurez besoin de deux adaptateurs Wi-Fi USB, ou un capable de fonctionner à la fois en mode point d’accès / géré et en mode client.

Au lieu d’une distribution Linux standard, vous devrez installer OpenWRT sur votre carte SD pour la transformer en un routeur à part entière. Vous pouvez utiliser une autre distribution Linux si vous préférez, mais OpenWRT fournit une interface Web pratique pour la configuration lorsque vous n’êtes pas à la maison.

Si vous utilisez Windows, vous devrez également installer PuTTY ou un autre client SSH pour Windows avant de commencer.

Étape 1: installer OpenWRT

Écran de l'outil de clignotant Etcher SD

Tout d’abord, téléchargez le firmware OpenWRT pour votre modèle de Raspberry Pi. Vous pouvez trouver les images les plus récentes du Wiki OpenWRT.

Décompressez le fichier téléchargé en utilisant 7zip ou un autre gestionnaire d’archives de fichiers approprié, puis flashez le fichier IMG sur votre carte avec Etcher.

Cet outil devrait détecter automatiquement votre carte SD; il vous suffit de sélectionner votre fichier image, sélectionnez le bon lecteur par lettre, puis cliquez sur Éclat.

Une fois cela fait, replacez votre carte microSD dans votre Raspberry Pi et laissez-la démarrer.

Étape 2: configuration initiale

Par défaut, OpenWRT utilise par défaut une adresse IP statique de 192.168.1.1, qui est l’IP de passerelle par défaut pour de nombreux routeurs. Vous devrez modifier cela pour éviter les conflits. Connectez votre Pi à votre PC à l’aide d’un câble Ethernet; vous devrez peut-être d’abord définir une adresse IP statique sur votre PC.

Plutôt que de gérer la configuration à l’aide de LuCI, l’interface Web d’OpenWRT, vous allez le faire manuellement pour vous assurer que la configuration est correctement définie. Chargez PuTTY ou votre client SSH et connectez-vous à 192.168.1.1 d’abord, avec le nom d’utilisateur racine.

Vous recevrez un premier avertissement de sécurité lors de votre première connexion; cliquez Oui et continuez. C’est une bonne idée à ce stade de définir un mot de passe; faites cela en tapant passwd à la fenêtre du terminal.

Configurer les paramètres réseau et pare-feu

Vous devez modifier deux fichiers—/etc/config/network et /etc/config/firewall… avant de poursuivre. Commencez par taper ce qui suit pour modifier le fichier:

vim /etc/config/network

Ensuite, appuyez sur I pour modifier le texte et inclure les éléments suivants:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option force_link '1'
option proto 'static'
option ipaddr '192.168.38.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wwan'
option proto 'dhcp'
option peerdns '0'
option dns '8.8.8.8 8.8.4.4' ## Google DNS servers

config interface 'vpnclient'
option ifname 'tun0'
option proto 'none'

Une fois que vous avez terminé, appuyez sur la touche Esc clé et type:wq pour enregistrer et quitter. Puis portez votre attention sur le fichier de configuration du pare-feu:

En relation :  5 façons de vous protéger contre les enregistreurs de frappe
vim /etc/config/firewall

Robinet je pour modifier, puis recherchez (ou ajoutez) une zone pour la section WAN, qui devrait ressembler à ceci:

config zone
option name wan
option network 'wan wan6 wwan'
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

Type redémarrer et attendez que le Raspberry Pi redémarre avec une nouvelle adresse IP: 192.168.38.1.

Étape 3: mise à jour et installation de packages

Ensuite, vous devrez mettre à jour OpenWRT. Pour ce faire, vous allez emprunter le Wi-Fi interne du Pi et le configurer initialement pour se connecter à votre réseau Wi-Fi existant. Vous devrez peut-être changer votre adresse IP statique en 192.168.38.2 ou une adresse similaire dans cette plage pour vous permettre de vous connecter.

Une fois connecté, saisissez l’adresse IP de votre Raspberry Pi dans votre navigateur pour accéder au tableau de bord d’administration d’OpenWRT. Utilisez votre nom d’utilisateur et votre mot de passe pour y accéder, puis accédez à Réseau> Sans fil. Vous ne devriez voir qu’un seul appareil Wi-Fi pour le moment, alors cliquez sur Analyse pour trouver votre réseau Wi-Fi, puis Rejoignez le réseau quand vous le trouvez.

Vous devrez saisir votre mot de passe Wi-Fi sous Phrase de passe WPA, avant de frapper Soumettre.

Vous devriez maintenant voir les paramètres de connexion pour votre connexion Wi-Fi. Aller à Réglages avancés et définissez votre Code postal pour correspondre à votre emplacement; votre Wi-Fi pourrait ne pas fonctionner autrement.

Reconnectez-vous à votre Pi en utilisant une nouvelle adresse IP sur SSH (en acceptant l’avertissement de clé de sécurité RSA). Vous devez d’abord mettre à jour votre appareil en tapant:

opkg update

Gardez un œil sur cela, en tapant Oui lorsque vous y êtes invité.

Installation des pilotes Wi-Fi USB

Une fois que vous avez installé toutes les mises à jour, installez les pilotes dont vous avez besoin pour votre adaptateur Wi-Fi USB. Ceci est nécessaire pour se connecter aux points d’accès Wi-Fi lorsque vous êtes en déplacement. Vous allez également installer les outils dont vous aurez besoin pour les connexions VPN à l’aide d’OpenVPN, ainsi que nano, un éditeur de fichiers de terminal plus facile à utiliser.

C’est là que votre méthode peut varier; J’avais un adaptateur Wi-Fi chipset RT2870, donc les commandes suivantes devraient fonctionner si vous le faites aussi:

opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils openvpn-openssl luci-app-openvpn nano
ifconfig wlan1 up
reboot

Si vous ne disposez pas d’un adaptateur Wi-Fi chipset RT2870, ou si vous n’êtes pas sûr, branchez votre adaptateur Wi-Fi et saisissez ce qui suit dans le terminal SSH:

opkg install kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils
lsusb

Une fois les fichiers installés, vous verrez une liste des appareils connectés. Trouvez tous ceux qui se réfèrent à un adaptateur sans fil et recherchez les instructions d’installation pertinentes pour votre appareil.

Écran de la fenêtre du terminal à mastic OpenWRT

Étape 4: Configurer le point d’accès Wi-Fi

Si votre adaptateur Wi-Fi USB est connecté, vous pouvez maintenant configurer les deux connexions Wi-Fi. Retournez au tableau de bord LuCI, sous Sans fil, et supprimez les deux connexions réseau. Le dispositif radio0 est votre Wi-Fi intégré, tandis que radio1 est votre adaptateur USB Wi-Fi.

Configurez votre Wi-Fi intégré en cliquant sur Ajouter. Vérifiez les points suivants:

  • Mode est réglé sur Point d’accès
  • ESSID est défini sur un nom de réseau de votre choix; la valeur par défaut est OpenWRT
  • Réseau est réglé sur Lan
  • En dessous de Sécurité sans fil, Chiffrement est réglé sur WPA2-PSK
  • Clé est défini sur un mot de passe approprié

Une fois que vous avez terminé, appuyez sur sauvegarder puis revenez à la Sans fil menu. Suivez les instructions précédentes pour la connexion initiale afin de définir radio1 (votre adaptateur USB Wi-Fi) à votre réseau existant. C’est également là que vous devrez analyser et changer de réseau lorsque vous vous trouvez dans un nouvel emplacement.

En relation :  Comment enregistrer de l'audio avec un microphone USB sur Android

Menu sans fil OpenWRT LuCI Dashboard

Vous devriez maintenant avoir deux connexions Wi-Fi en cours d’exécution, l’une en tant que point d’accès pour vos appareils Wi-Fi et l’autre en tant que connexion Internet de votre appareil à votre réseau Wi-Fi existant. Essayez la connexion à votre Pi à ce stade avec votre smartphone ou ordinateur portable pour confirmer que cela fonctionne.

Si cela fonctionne, déconnectez votre Pi de la connexion Ethernet avec votre PC.

Étape 5: se connecter au VPN et modifications finales

Vous aurez besoin d’un fichier de configuration OpenVPN (OVPN) pour connecter votre Pi à votre fournisseur et serveur VPN choisi. Si vous en avez un, téléchargez-le sur votre Pi en utilisant un client SCP comme WinSCP où vous pouvez vous connecter avec votre nom d’utilisateur et votre mot de passe administrateur.

Renommez le fichier en vpnclient.ovpn et téléchargez-le dans le /etc/openvpndossier. Suivez les instructions trouvées sur le site d’OpenWRT pour configurer votre Pi pour les connexions VPN. Le seul léger changement sera sous la section 4 pour la configuration du profil du client VPN, où vous n’aurez pas besoin d’utiliser la première cat outil pour insérer votre vpnclient.ovpn fichier, car il est déjà en place.

Dès que vous avez terminé, votre connexion VPN devrait s’activer automatiquement. Vérifiez que votre adresse IP sortante a changé; si ce n’est pas le cas, redémarrez votre Pi et vérifiez que votre connexion est active.

Trouvez ceci en allant sur le OpenVPN section de LuCI, répertoriée sous Prestations de service en haut du tableau de bord. S’il est connecté, vpnclient sera répertorié comme Oui sous le Commencé colonne.

OpenWRT LuCI Dashboard OpenVPN Menu

Étape 6: Enregistrez votre appareil sur le Wi-Fi public

Votre Pi est presque prêt à ce stade, mais si vous vous êtes déjà connecté à un réseau Wi-Fi public, vous savez que vous devrez généralement vous authentifier à l’aide d’un portail captif, que ce soit pour payer ou enregistrer votre appareil. Parce que votre Pi est maintenant configuré pour se connecter automatiquement via VPN (et devrait empêcher la connexion autrement), ces portails seront généralement bloqués.

Pour contourner ce problème, configurez votre adaptateur USB Wi-Fi pour faire correspondre l’adresse MAC avec un appareil que vous pouvez utiliser pour vous connecter et vous authentifier d’abord avec un réseau Wi-Fi public, tel que votre smartphone. Une fois que vous avez cela, tapez:

nano /etc/init.d/wan-changer

Dans la fenêtre d’édition, ajoutez ce qui suit (en remplaçant l’espace réservé XX pour votre MAC) et appuyez sur Ctrl + X, suivi par Oui sauver.

#!/bin/sh /etc/rc.common

START=10

start() {
 uci set [email protected][1].macaddr='XX:XX:XX:XX:XX:XX'
 uci commit network
}

Enfin, exécutez les commandes suivantes pour configurer le script pour qu’il s’exécute automatiquement au démarrage de votre Pi:

chmod +x /etc/init.d/wan-changer
/etc/init.d/wan-changer enable

Redémarrez pour vérifier que tout fonctionne bien. Vous devez également vérifier toute fuite DNS pour vous assurer que votre connexion VPN fonctionne correctement. La plupart des fournisseurs de VPN proposent un outil qui vous aidera à cet égard.

Wi-Fi sécurisé où que vous alliez, garanti

Votre Raspberry Pi devrait maintenant être configuré et prêt à fonctionner en tant que routeur de voyage VPN, ce qui signifie que vous pouvez surfer en toute sécurité dans n’importe quel hôtel ou café que vous visitez. Grâce au tableau de bord LuCI, vous pouvez facilement vous connecter à n’importe quel nouveau réseau Wi-Fi via votre navigateur Web.

Consultez notre liste des meilleurs services VPN pour trouver un service VPN qui répond à vos besoins. Si cela était trop avancé pour vous, vous pourriez également envisager d’autres façons de configurer un VPN à la maison.

Moyens Staff
Moyens I/O Staff vous a motivé, donner des conseils sur la technologie, le développement personnel, le style de vie et des stratégies qui vous aider.